
Новая версия T-FLEX CAD содержит множество изменений и дополнительных возможностей, позволяющих повысить эффективность проектирования и ускорить выпуск высококачественной продукции на рынок с меньшими затратами. Многие нововведения стали ответом на запросы пользователей.
Основное внимание было уделено:
●Повышению удобства и интуитивности пользовательского интерфейса.
●Созданию удобных окон для работы с элементами деталей и сборок.
●Переработке дерева модели меню документов.
●Уменьшению времени построения и пересчёта проекций, а также повышению общего быстродействия работы системы.
●Улучшению инструментов редактирования элементов чертежей и 3D моделей.
●Усовершенствованию механизма выгрузки доработанных деталей из сборки с последующим их обновлением.
●Расширению возможностей 3D моделирования с помощью новых команд и дополнительных опций.
Новое лицо системы
Интерфейс системы подвергся глубокой переработке. Благодаря этому использование программы стало более эффективным, комфортным и интуитивным.

Ленточный интерфейс
Команды и операции теперь легко найти визуально, так как они располагаются на ленте и распределены по вкладкам и группам, позволяя осуществлять максимально быструю навигацию. Ориентироваться во вкладках и находить нужные команды и операции не составит труда ни начинающему, ни опытному пользователю. Существенным преимуществом нового интерфейса стало то, что большинство команд и операций можно активировать всего лишь одним нажатием.

Лента подстраивается под текущий режим. Например, вкладки 3D Модель и Чертёж меняются при переключении между 3D и 2D окнами - нужная операция или параметр всегда под рукой.
Лента запоминает, на какой вкладке располагалась последняя выбранная команда. Если выбрать команду с вкладки “Измерение” в 3D окне, а потом продолжить работу в 2D окне, то при следующем переходе в 3D окно будет вновь активна вкладка “Измерение”.
В заголовке окна находится панель быстрого доступа, на которой расположены команды для работы с документом (сохранить, отменить действие и др.). Эти команды доступны всегда и не зависят от активной вкладки. Сюда же вынесена команда вызова окна параметров документа
, а также некоторые другие часто востребованные команды.

Кнопка «Файл»
аналогична пункту текстового меню Файл и сохранила ту же функциональность.
Текстовое меню, в котором содержится полный набор команд, можно вызвать нажатием на кнопку
.

В правом верхнем углу находятся: поле для отображения интеграции с системой T-FLEX DOCs
, выпадающее меню справки
, выпадающее меню настроек системы
, команда для отображения окна приветствия
, команда для включения полноэкранного режима
.

В выпадающем меню
можно настроить видимость различных вкладок ленты.
Выпадающее меню настроек системы
содержит большинство команд пункта Настройка из классического текстового меню.
Вы можете скрыть Ленту двойным кликом на любой вкладке, чтобы освободить рабочее пространство. Лента вновь появляется при выборе любой из её вкладок. Восстановить ленту можно повторным двойным кликом.

Вкладки можно переключать с помощью колеса мыши, если навести на них курсор и вращать колесо.

Для персональной настройки в команде Настройка на вкладке Лента существует возможность редактирования существующих вкладок и создания собственных вкладок с необходимыми командами и операциями. Здесь же можно изменять размеры иконок команд в ленте.

Если несколько равноценных команд в ленте объединены в выпадающий список, то последняя выбранная команда запоминается.
.
При желании вы всегда можете вернуться к классическому интерфейсу, который использовался в предыдущих версиях системы. Для этого нужно отключить режим ленты в окне Настройка на закладке Параметры.


При первом запуске система сама предложит Вам выбрать интерфейс.
![]()
Повышение эффективности работы с несколькими окнами
Повысилась эффективность работы с несколькими рабочими окнами. Панель фильтров, панель Вид и автоменю теперь появляются у границ активного окна. Это нововведение заметно сократило перемещение курсора и освободило рабочее пространство чертежа.
Расположение панелей можно изменять, используя соответствующие настройки в окне Параметры документа.
Улучшилась поддержка мониторов высокого разрешения.
Активное рабочее окно теперь выделяется оранжевой рамкой.

Панель Вид
Панель Вид теперь изменяется в зависимости от того, в каком окне она открыта. В 2D окне, 3D окне и окне фотореалистичного вида отображается разный набор команд. Кроме того, на панель Вид вынесены некоторые команды, которые часто используются в работе.

На панель Вид для 3D окна добавлены три типа отображения элементов: Показывать очерковые линии, Показывать скрытые линии, Показывать рёбра. Они дублируют параметры опций 3D вида, предоставляя удобный и быстрый доступ к ним.

Теперь камеру, плоскость обрезки и сечение можно создать или выбрать с помощью выпадающего списка на панели Вид.

Добавлена возможность изменять качество изображения в 3D сцене прямо из панели Вид с помощью выпадающего списка.
Если в сцене нет выбранных тел, то опция устанавливает качество всех тел в сцене при выборе значения из списка. Если в сцене есть выбранные тела, опция изменяет только их качество.
По умолчанию. Для тел устанавливаются значения из параметров документа, для фрагментов значения берутся из документа фрагмента и т.д.
Если для всех выбранных тел, или для всех тел в сцене качество совпадает, то оно будет помечено в списке флагом. Если качество отличается, то флаг будет отсутствовать.
Отображение толщины линий вынесено на панель Вид.

Динамическая панель
При вызове контекстного меню по правому клику мыши теперь появляется динамическая панель. На этой панели располагаются часто используемые команды. Набор команд динамической панели зависит от типа выбранного элемента.

Крупные иконки
Для работы на мониторах высокого разрешения появился дополнительный набор крупных иконок. Выбрать их можно в команде Настройка.

![]()
Дерево 3D модели
Функциональные возможности окна 3D Модель были расширены. Это упростило работу с моделью и сократило частоту использования контекстного меню.
Теперь отображение дерева доступно также и в 3D сцене, что удобно в ситуациях, когда окно 3D модель скрыто.
В 3D окне дерево модели вызывается нажатием иконки
в левом верхнем углу 3D сцены и может быть скрыто в любой момент.

При работе с 3D моделью дерево модели автоматически раскрывается в 3D сцене, если окно 3D Модель в какой-то момент становится недоступным. Это происходит, например, при входе в команды создания или редактирования 3D элементов. Если раскрытие дерева при активации команд не требуется, достаточно закрыть его один раз с помощью
, и система запомнит это состояние.
У дерева модели в 3D сцене есть специальная инструментальная панель, которую можно скрыть нажатием на специальную кнопку.
.
Дерево можно расширить. Для этого необходимо поместить курсор на правый край инструментальной панели и переместить его, зажав левую кнопку мыши.

Благодаря дереву модели расположенному в 3D сцене перед пользователем может быть одновременно открыто и окно параметров текущей операции, и дерево модели. Это избавляет от лишних переключений между окнами, если требуется выбрать элемент из дерева модели для использования в операции.
Например, при вставке фрагмента “Камера” можно выбрать целевую систему координат для его привязки непосредственно в дереве модели.

Как в дерево модели в 3D окне, так и в окно 3D Модель добавлена инструментальная панель. На этой панели находятся опции для переключения между состояниями дерева модели, строка поиска и выпадающий список колонок.
![]()
Строка поиска позволяет находить элементы в дереве 3D модели по их имени или части имени. После завершения поиска в дереве остаются только элементы с подходящими именами.

В окно 3D Модель добавлена возможность отображения некоторых параметров элементов в специальных колонках. Колонки позволяют быстро изменять параметры элементов и получать информацию о них, не прибегая к помощи команд редактирования или контекстного меню. Параметры можно изменять сразу для нескольких выбранных элементов.
Например, чтобы скрыть несколько рабочих плоскостей, не нужно заходить в контекстное меню каждой плоскости и вызывать специальную команду. Можно просто выбрать все нужные рабочие плоскости в дереве модели и нажать на пиктограмму
в колонке “Видимость”.

Если изменение параметра для элемента дерева недоступно, пиктограмма в колонке не появляется.
Для включения отображения колонок в дереве используется выпадающий список.Имеется возможность сортировки записей по колонкам.
В контекстном меню дерева модели появились новые команды: Перейти к элементам, Открыть в новом окне, Скрыть элемент.
При использовании команды Перейти к элементам в дереве будут отображены только выбранные элементы, что удобно, когда вы работаете только с некоторыми телами или фрагментами. Для возврата к обычному режиму используются опции переключения состояния:
,
,
.

Команда Открыть в новом окне позволяет выносить любые элементы 3D модели в отдельное окно. Это окно можно перемещать по экрану. Оно сохраняет всю функциональность окна 3D Модель. Новое окно можно поместить в удобном месте. Это позволяет избавиться от необходимости каждый раз перемещать курсор через весь экран, чтобы выбрать элемент дерева модели.

После использования опции Скрыть элемент, выбранные элементы станут невидимы в дереве модели. Например, можно скрыть неиспользуемые элементы, чтобы не отвлекаться на них в процессе работы.

Если установлен флаг Показывать скрытые элементы, скрытые элементы отображаются, но окрашены в серый цвет. Названия таких элементов выделены курсивом, чтобы не путать их с погашенными элементами.

Чтобы вновь показать элемент в окне нужно воспользоваться опцией Показать элемент. Чтобы показать все скрытые элементы используется опция Сделать все узлы видимыми.

Команды для настройки отображения дерева модели, такие как Параметры и Представление, перенесены в отдельный пункт Вид контекстного меню дерева модели.

Окно Меню документов
Окно Меню документов теперь обновляется автоматически при удалении, добавлении и переименовании файлов формата GRB в папках, связанных с библиотеками. Таким образом, если файл добавлен в папку в проводнике Windows, то он сразу же отобразится в меню документов. При необходимости можно удалять с диска связанные с библиотеками папки прямо из меню документов с помощью опции Удалить с диска.
Добавлена возможность обмена файлами между библиотеками Меню документов и папками Windows с помощью команд Вырезать, Копировать, Вставить и Drag’n’drop.
Перенос файла из папки Windows в окно Меню документов с помощью Drag’n’drop:


Нажатие на стрелку
рядом с иконкой команды Открыть конфигурацию вызывает выпадающий список всех установленных конфигураций. С его помощью удобно открывать/закрывать конфигурации.

Теперь в результате поиска в меню документов отображаются все файлы, имена которых удовлетворяют поисковому запросу.

Добавлено отображение колонок с информацией о файлах. Эту информацию можно редактировать. Имеется возможность сортировки по колонкам.

Колонка Видимость позволяет скрывать конфигурации, библиотеки и файлы в окне. Для этого нужно кликнуть по иконке
напротив нужного элемента. Чтобы показывать/не показывать скрытые элементы необходимо кликнуть по заголовку колонки.

Добавлен предварительный просмотр библиотек и групп библиотек.

В контекстном меню появилась команда Открыть папку. После её активации открывается папка Windows, в которой располагается выбранная конфигурация, библиотека или документ.

Новая конфигурация библиотек теперь не сохраняется при создании. Её можно сохранить с помощью специальных команд контекстного меню, или перед завершением работы.
Окно Элементы модели
Для отображения всех присутствующих в документе элементов добавлено новое окно Элементы модели.
В окне отображаются как 2D, так и 3D элементы. Для каждого из элементов доступно контекстное меню с соответствующим набором команд.
При выборе элементов из списка, они подсвечиваются в сцене и на чертеже.
Это окно особенно полезно при работе с чертежами. Оно предоставляет информацию по каждому элементу чертежа на текущей странице или на всех страницах документа.
В окне могут отображаться как 2D, так и 3D элементы.
Для настройки отображения элементов используется фильтр в верхней части окна.
С помощью опции
можно включать и отключать группировку элементов по типу.
Для обновления содержания окна используется опция
.
В правом углу окна можно выбрать колонки, в которых будет выводиться информация об элементах.

В окне можно выбирать элементы для использования в текущей операции, например, выбрать линии изображения для операции Копирование.
Окно Ссылки
Окно Ссылки показывает все внешние файлы, которые используются в текущем документе, и позволяет ими управлять. В частности, в нем показываются вставленные в сборку файлы фрагментов, используемые файлы баз данных и текстуры материалов.
Данное окно заменило функциональность существовавшего в предыдущих версиях системы диалога Ссылки и включило в себя некоторые новые возможности. Новое окно предоставляет более полный набор команд и дополнительных инструментов для удобной работы со ссылками.
При помощи контекстного меню можно выполнять некоторые операции над ссылками: открывать внешние файлы, менять тип ссылки с внутренней на внешнюю, изменять ссылки на расположение файлов и т.д.

Например, если изменилось имя файла фрагмента, вследствие чего он исчез из сборки, можно просто выбрать переименованный файл с помощью команды Выбрать файл, и он вновь займёт своё исходное место.
С помощью окна Ссылки можно переименовывать файлы и перемещать их в другие папки Windows, при этом сохраняя их связь с текущей сборкой.
Поиск ссылок и элементов можно производить с помощью строки поиска.
![]()
С помощью фильтра можно настроить отображение элементов, а также внутренних и внешних ссылок в окне.

Из выпадающего списка можно выбрать колонки для отображения информации об объектах.

Среди прочих следует выделить колонку “Актуальность”:
Пиктограмма
в колонке означает, что ссылка актуальна.
Пиктограмма
означает, что файл по заданной ссылке не найден.
Пиктограмма
означает, что изменения из файла не попали в сборку, и требуется обновление документа.
Если включён режим интеграции с T-FLEX DOCs, то в окне появляются дополнительные колонки. Эти колонки предназначены для ведения коллективной разработки.

При включённом режиме группировки
объединяются связанные с одной ссылкой объекты.

Окна диалогов установок системы и параметров документа
Диалоговые окна Установки и Параметры документа (Статус) визуально изменились. Теперь все бывшие закладки этих диалогов расположены в левой части в виде списка. При выборе того или иного параметра или опции в нижней части окна появляется подсказка.

Компоновка некоторых закладок была изменена по сравнению с предыдущей версией для упрощения поиска нужной опции.
Кроме того, добавлена закладка Все, на которой перечислены все доступные в окне настройки. Важной особенностью этой закладки является наличие кнопок сортировки и строки поиска. Теперь, чтобы найти нужную настройку, достаточно ввести её название или его часть.

В окне Параметры документа можно настроить параметры, относящиеся как ко всему документу, так и к каждой его странице. Для этих целей используются закладки Страница и Документ.

Страницу можно выбрать в выпадающем списке в верхней части окна. Настроить тип страниц для этого выпадающего списка можно с помощью списка Фильтр:

Кроме того, с помощью кнопки [Копировать в…] можно передавать параметры одной страницы в другую. Копировать можно как сразу все параметры страницы, так и параметры с отдельных закладок.
Для копирования можно отметить сразу несколько страниц. Это позволяет быстро переносить настройки страниц и управлять этими настройками при работе с многостраничными документами.

Работа с несколькими мониторами
Теперь в T-FLEX CAD можно открывать одновременно несколько главных окон для одного документа. Основное назначение этого режима – отображение одного документа на нескольких мониторах.
Например, если к компьютеру подключены два монитора, то на один монитор вы можете вывести 3D окно с моделью, а на другой – рабочий чертёж с проекциями той же модели. Выполненные операции отображаются во всех главных окнах, которые связаны с одним документом, так что изменения в модели на одном мониторе показываются на проекциях на другом сразу после обновления.

Несмотря на то, что работа идёт с одним документом, главные окна программы независимы друг от друга. В каждом из них доступен выбор команд посредством меню или ленты, диалоги ввода параметров и другие элементы пользовательского интерфейса. Набор документов, доступных для работы в каждом из главных окон может различаться. Существует возможность переноса документов из одного главного окна в другое. При закрытии документа в одном из главных окон система спросит о необходимости сохранения изменённого документа только при закрытии самого последнего окна с документом.
Окно Параметры всегда появляется в активном главном окне. Остальные окна, такие как 3D Модель, Меню документов и т.д., существуют в одном экземпляре только в одном из главных окон.
Дерево модели в 3D сцене доступно для каждого главного окна.
При вызове диалогового окна, например, редактора переменных, в одном из главных окон все остальные главные окна становятся недоступны до его закрытия.
При открытии нового главного окна вы можете указать размещение видов.
Главные окна нумеруются. Номер окна выводится в его заголовке в круглых скобках. Это помогает выбрать нужное окно для переключения или переноса рабочих окон.
![]()
Для активации многооконного режима служит команда - Открыть новое главное окно, расположенная на вкладке Вид.

Там же находится команда для переноса рабочего окна документа из одного главного окна программы в другое, а также команда открытия нового окна документа, в котором можно задать другое главное окно программы.
Закладки документов
В работу с закладками было внесено несколько изменений.
Имя нового документа теперь зависит от использованного для его создания прототипа. Например, при создании чертежа на основе прототипа “2D Деталь”, документу будет автоматически присвоено имя “2D Деталь 1” в соответствии с именем прототипа. Это позволяет конкретизировать именование новых документов.
![]()
Несохраненные документы теперь помечаются символом “*”. С его помощью можно отслеживать сохранность информации и избегать её потери. После сохранения документа символ пропадает.
В контекстном меню закладок появились дополнительные опции: Фиксированная ширина, Новое главное окно и Перенести в главное окно.
При включённой опции Фиксированная ширина, ширина закладок становится одинаковой, упрощая визуальное восприятие.
![]()
Опция Новое главное окно позволяет создать новое окно и скопировать в него выбранную закладку.
Для переноса закладки в другое окно используется опция Перенести в главное окно. Окно можно выбрать в выпадающем списке.
Добавлена новая возможность закрытия документа. Теперь это можно сделать, нажав на его закладку колесом мыши.
3D Линейки
В различных командах 3D моделирования изменение длины отображается в 3D сцене с помощью линейки, а изменение угла – с помощью транспортира. Линейки и транспортиры позволяют точно задать значение без использования клавиатуры и лишних перемещений курсора.

Линейки и транспортиры отображаются как при создании операций, так и при редактировании во время перемещения объектов.
Задать цвета для линеек и транспортиров можно в окне Установки.

Информационные сообщения
Некоторые системные сообщения в T-FLEX CAD 15 отображаются в верхней части окна и не блокируют работу системы.
![]()
Повышение производительности
Многие внутренние механизмы работы системы были оптимизированы для повышения быстродействия. Это относится к процессам пересчёта моделей, работы с большими сборками и чертежами.
В системе используется новая версия ядра Parasolid, что также повлияло на ускорение работы и повышение точности моделирования.
Увеличение скорости пересчёта некоторых 3D операций достигает более чем 30%. Выросла также скорость открытия файлов больших сборок.
Запуск программы занимает меньше времени.
Переход к черчению на плоскости происходит в два раза быстрее, чем в версии 14.
Улучшилась поддержка многоядерных процессоров, что позволило ускорить расчёты моделей различных типов.
По сравнению с предыдущей версией также существенно увеличилась скорость создания и пересчёта проекций, включая разрезы, сечения, местные виды. Значительный прирост производительности происходит при пересчёте проекций неуникальных тел.
Ниже приведено сравнение скорости работы с проекциями для T-FLEX CAD 15 и T-FLEX CAD 14.
На графике показана зависимость времени пересчёта проекций от количества тел в сборке:

Новые и улучшенные возможности моделирования
Во многих командах трёхмерного моделирования были проведены существенные доработки для улучшения интуитивности, наглядности, а также расширения возможностей.
Примитивы
Новые команды, объединённые в группу Примитив, позволяют существенно упростить создание базовых геометрических тел.
Выпадающий список меню Примитив содержит следующие команды: Параллелепипед, Цилиндр, Конус, Шар, Тор, Призма, Пирамида.

Для каждого из тел доступен манипулятор, с помощью которого можно определить положение тела в сцене, и набор манипуляторов для изменения основных размеров.
Примитивы сделали создание моделей определённых типов проще и удобнее, так как теперь вместо создания профиля базового тела и его выталкивания нужно активировать всего одну команду.

Для всех команд группы примитив, кроме команды Пирамида, доступна опция
Симметрия. После её использования создаётся единое тело примитива, состоящее из двух симметричных частей. При этом не применяются дополнительные операции. Исходная система координат примитива оказывается в центре тела. Для примитивов Шар и Тор опция включена по умолчанию.

Для всех команд группы примитив доступна опция
Листовое тело. При использовании опции у тел удаляются основания, и остаются только боковые грани.

Для примитивов Параллелепипед, Сфера, Цилиндр и Тор имеется возможность создания тонкостенного элемента.

Параметры тонкостенного элемента можно задать в окне Параметры.

Для примитивов Параллелепипед и Цилиндр доступно задание донышка и крышки тонкостенного элемента.
Имеется возможность привязывать размеры примитивов к существующей в сцене геометрии.

Примитив будет изменяться вместе с телом, к которому привязаны его параметры.
Для разрыва связи можно воспользоваться специальной опцией, которая появляется возле соответствующего параметра.

Привязка к геометрии не может быть использована в случае перезадания исходной системы координат примитива. В этом случае появляется соответствующее сообщение.
Листовой металл
Гибка
Отбортовка
В операцию Гибка добавлена возможность создания отбортовки. Для этого нужно выбрать соответствующую операцию в окне параметров гибки. Доступно шесть типов отбортовки: закрытая, открытая, каплевидная, трубчатая, s-форма, двойная.
|
Трубчатая |
Каплевидная |
|
Двойная |
|
|
Открытая |
Закрытая |

S- форма
Добавить рёбра
В операциях Приклеить и Отбортовка добавлена новая опция
Добавить рёбра. Опция даёт возможность выбора нескольких последовательных рёбер для участия в операции. Каждое следующее ребро должно принадлежать к той же грани и примыкать к предыдущему выбранному ребру.

Если выбрано более одного ребра, то в окне Параметры появляется раздел Зазоры, в котором можно задать тип зазоров и их размер.

Создание контурной кромки
В операцию Приклеить добавлена возможность создавать контурные кромки. В данном случае кромка – это операция листового металла, форма которой задана образующей. Результат этой операции приклеивается к краям базового листового тела, образуя с ним единую конструкцию.

В качестве образующей для определения будущей геометрии кромки необходимо выбрать профиль, трассу или путь. Образующая не может быть замкнутой. Все её точки должны лежать в одной плоскости. Образующую можно задать прямыми или дугами окружности.
Для операции необходимо выбрать ребро, к которому будет приклеена контурная кромка, и образующую, а затем указать прилегающую точку и направление профиля. Если образующая касается ребра, то контурная кромка строится сразу после выбора образующей.
Кромки могут образовывать замкнутый контур. При этом можно задать условия ослабления и зазоры в местах стыка кромок для всего тела.

Гибка по сечениям
Добавлена новая операция Гибка по сечениям, которая позволяет моделировать сложные листовые тела на основании двух сечений.


Для создания операции нужно выбрать два профиля, расположенных на двух параллельных плоскостях. Профили могут состоять из гладко состыкованных дуг или прямых.
Можно настроить количество сгибов, которые создаются в сегментах, образованных двумя дугами или прямыми.
Тело, полученное в результате выполнения этой операции, может быть разогнуто операцией SMU: Разгибание.


Можно также создавать тела из двух замкнутых профилей.
Для каждого из замкнутых профилей необходимо дополнительно задать начальную точку отсчёта и направление построения последовательности гибок с помощью соответствующих опций.
При использовании опции Фасеточное приближение строится поверхность, которую можно впоследствии преобразовать в листовой металл.
Разгибание
Добавлена возможность разгибания/повторной гибки незамкнутых конических граней листовых тел.

Добавлена опция
Выбрать точку для задания плоскости разреза. С её помощью можно разгибать замкнутые грани цилиндрических листовых тел и усечённых конических листовых тел, а также произвольные развёртывающиеся поверхности. Для этого нужно выбрать точку и направление разгибания выбранной грани. Разогнутые грани могут быть повторно согнуты с помощью операции Повторная гибка.


Преобразование тела в листовой металл
Параметры ослабления
В команду Преобразование тела в листовой металл добавлены настройки параметров изолирующих ослаблений. Теперь можно задать их глубину и ширину. Кроме того, изолирующие ослабления теперь располагается за пределами сгибаемого листового тела. Данное изменение позволяет получать более реалистичные модели на основе листовых тел. |
|
|
Изолирующие ослабления настраиваются в разделе Ослабления окна параметров. Их параметры по умолчанию задаются в команде SMP: Параметры. |
|
Добавлен новый тип ослаблений – Сварочные. При его использовании образуется оптимальный стык в области гиба, который может быть использован для сварки. |
Направление придания толщины
Добавлена возможность изменения направления придания толщины относительно исходной заготовки. Доступны режимы: внутрь, симметрично и наружу.


Внутрь |
Симметрично |
Наружу |
Таблица гибов
Для работы с листовым металлом была добавлена команда Таблица гибов.
С помощью команды Таблица гибов можно просматривать все гибы для каждого из существующих в сцене тел. В соответствующих колонках отображаются основные параметры гибов. При выборе гиба в таблице он подсвечивается в сцене.

Таблицу можно выгрузить на страницу чертежа с помощью опции Создать на чертеже.

По траектории
В команде По траектории добавлена возможность использования твердого тела в качестве исходного объекта, перемещающегося вдоль выбранной траектории. При этом во время перемещения тело вращается вокруг заданной оси. След, оставляемый телом, может быть использован впоследствии, например, для булевой операции.
Таким образом возможно в частности моделировать след, который при обработке оставляет фреза.
У обрабатывающего тела можно выбирать используемые грани с помощью опции Выбрать используемые грани тела
. Только выбранные грани будут участвовать в операции. Если установить флаг Инвертировать, выбранные грани не будут участвовать в операции.
Например, требуется создать канавку на дверце. Для этого создаётся траектория на обрабатываемом теле и обрабатывающее тело нужной формы:
Траектория на обрабатываемом теле: |
|
Обрабатывающее тело. |
|
После активации команды эти элементы необходимо выбрать:

Для обрабатывающего тела задаётся ось вращения
и точка привязки оси вращения
.

Затем обрабатывающее тело перемещается вдоль заданной траектории, одновременно вращаясь вокруг указанной оси, формируя таким образом канавку. С учетом использования опции булевой операции вычитания в итоге получаем следующий результат:

Деформации
Общие изменения команд группы деформации
При создании деформаций теперь используются новые декорации, а перемещения и повороты вокруг осей осуществляются с помощью специальных манипуляторов. В командах Перекос и Скульптурная деформация узлы заменены на сферы, которые удобно выбирать. Это сделало использование команд деформации более комфортным и наглядным.

История преобразований теперь сохраняется в процессе выполнения операций, поэтому по клику правой кнопкой мыши отменяются не все преобразования модели, а только последнее. Это позволяет избежать ситуаций, при которых пользователь может случайно отменить все преобразования тела.
Реализована новая опция установки локальной системы координат (ЛСК) для операций деформации – Установить ЛСК на основе операции. В этом режиме при деформации объекта отслеживаются преобразования родительской операции.
При необходимости можно использовать старый режим – Установить ЛСК на основе ГСК.
В окне Параметры для всех команд появились опции Пометка тела и Синхронный просмотр.
При отключении опции Пометка тела, тело перестаёт подсвечиваться в сцене, что упрощает визуальное восприятие деформируемого объекта.

Вкл. |
Выкл. |
Опция Синхронный просмотр позволяет следить за деформациями тела в реальном времени. Отключение опции ускоряет пересчёт, т.к. при этом не требуется время на изменение твёрдого тела.

Вкл. Виден предполагаемый результат |
Выкл. Изменяются только декорации |
Скульптурная деформация
Были введены некоторые изменения для повышения удобства использования команды Скульптурная деформация:
Узлы сетки заменены на сферы. При выборе сферы появляется манипулятор, перемещающийся относительно глобальной системы координат.

Размер таблицы с координатами сфер теперь меняется вместе с изменением размера окна Параметры. При наведении курсора на одно из полей таблицы появится его номер в формате: (Номер строки, Номер столбца).
В режиме Интерполяция по точкам сетки можно добавить новую линию сетки, зажав <Alt> и указав на существующую в сцене горизонтальную или вертикальную линию без изменения деформирующего закона.
Теперь при активации опции
появится полупрозрачный параллелепипед, грани которого можно перемещать, тем самым изменяя область деформации.
При клике по линии, выбираются все узлы на ней.
Выбор нескольких сфер или линий происходит с нажатой клавишей <Ctrl>.
Масштабирование/скручивание
В команду Масштабирование/скручивание также введены изменения, упрощающие работу с ней.
Теперь после выбора тела, участвующего в операции, система сама создаёт ЛСК, на основе которого будут происходить деформации. При желании, пользователь может самостоятельно выбрать ЛСК для операции.
Добавлена возможность добавлять новые сечения нажатием левой кнопкой мыши по линии, соединяющей центры двух существующих сечений. Ранее требовалось создавать сечение в окне свойств и вручную перемещать его на нужную позицию.

Перемещение/Масштабирование вдоль оси X теперь осуществляется относительно начала координат используемой системы координат. Манипулятор перемещения/масштаба существует для обоих начальных эллипсов. Это сделано для обеспечения симметрии создаваемого тела.
Манипулятор локальной системы координат теперь можно скрыть с помощью соответствующего флага в окне Параметры.
Разделение граней
Теперь многоконтурные операции и профили могут быть выбраны в качестве разделяющих и разделяемых элементов. Данная возможность позволяет исключить лишние действия, если требуется создать разделение граней несколькими контурами или разделить многоконтурное тело.
В примере для разделения грани тела был выбран многоконтурный профиль:

Отверстия
Перемещение отверстий вместе с узлами
Если переместить 3D узел на другую грань тела с помощью команды Перезадать или по какой-либо другой причине, то созданное по этому узлу отверстие переместится вместе с ним. 3D узел может быть перемещён в пределах одного тела или многотельной операции. Данная функциональность работает с отдельными 3D узлами или массивами 3D узлов.


Если для отверстия было задано направление, оно будет сброшено, и отверстие будет построено по нормали к новой грани.
Если отверстие построено до заданной грани, то его пересчёт не производится, и оно будет расположено в той же плоскости, независимо от положения 3D узла.
Создание соосных отверстий без объединения тел
С помощью опции Создавать соосные тела
можно создавать соосные отверстия в нескольких телах или фрагментах, и при этом они не будут объединены в одно.

Для каждого тела создаётся независимое отверстие.

Параметризация поддерживается на уровне общих переменных. Т.е. если задать размеры отверстия через переменные, то эти переменные сохранятся для каждого из отверстий.
3D Профиль
Добавлена возможность создания развёртки геликоида. Для развёртки используется опция Построить развёртку линейчатой поверхности. После выбора разворачиваемой грани, необходимо выбрать точку касания профиля и исходной грани. Создаётся развёртка не более чем одного витка геликоида. Геликоид должен быть создан командой Спираль.

Преобразования
Добавлена возможность разорвать ассоциативную связь между объектами в модели. Для этого используется опция Заменить на одно неассоциативное преобразование.
Опция полезна, если требуется позиционировать один объект относительно другого, а затем разорвать связи между этими объектами. После применения этой опции объект будет располагаться в абсолютных координатах.

Выбор всех граней, созданных операцией
В команды Копия, Симметрия и команды создания массивов в режиме Выбор граней добавлена опция Выбор всех граней, созданных операцией.
Теперь не требуется выбирать каждую из созданных одной операцией граней по отдельности. Для выбора всех граней достаточно одного клика, что существенно экономит Ваше время.
Например, при создании симметрии ребра жёсткости необходимо включить опцию
и выбрать операцию “Ребро жёсткости” в дереве модели. Вместо каждой отдельной грани в список заносится выбранная операция со всеми её гранями.

Система сама определяет набор граней, которые были созданы в указанной операции, и использует их при построении симметрии.
Также удобно использование этой возможности для выбора граней отверстий.
3D узел на сетке 3D изображения
В команде 3D узел добавлена опция для создания узла на сетке 3D изображения
. 3D узел, созданный на сетке импортированного 3D изображения можно затем использовать для создания или привязки других элементов модели. Например, на основе 3D узла можно создать локальную систему координат, которую можно использовать для привязки других тел и изображений.
В приведенном ниже примере по 3D узлам на 3D изображении была проложена трасса, а затем операцией Трубопровод был создан кабель .

Кроме непосредственного создания 3D узлов теперь можно выбирать точки на сетке 3D изображений и при выполнении некоторых команд моделирования. Для этого создан специальный фильтр: “Точка на сетке 3D изображения”.
Например, в команде Выталкивание в качестве точки, задающей направление выталкивания, можно выбрать точку на сетке 3D изображения.
Ребро жёсткости
Добавлена возможность создания ребра жёсткости в качестве отдельного тела. Для этого необходимо установить флаг Отдельное тело в окне Параметры.


Нововведение, в частности, позволяет создавать сварные конструкции с использованием рёбер жёсткости.
Данный способ часто применяется при моделировании сварной конструкции фланца и трубы.

Сглаживание рёбер
Расширены возможности операции Сглаживание рёбер. При установленном флаге Непрерывность по кривизне строится непрерывная сплайновая поверхность А-класса (поверхность типа G2), обеспечивающая плавный переход. Кривизна обоих выбранных для операции поверхностей в каждой точке их общей границы одинакова. Такие поверхности особенно полезны при моделировании изделий, для которых важно снизить сопротивление в текучих средах, например в автомобилестроении, авиации или судостроении.
![]()

Рабочие плоскости и поверхности
Параметры рабочих плоскостей и поверхностей
В параметрах рабочих плоскостей появилось несколько новых опций.
При установленном флаге Показывать все 2D элементы на 3D виде штриховки, линии изображения и другие элементы 2D изображений показываются в 3D сцене.

Когда флаг Показывать линии пересечения с рабочими плоскостями установлен, на странице рабочей плоскости отображаются не только границы самой рабочей плоскости, но и линии пересечения с другими рабочими плоскостями модели.

Линии пересечения плоскостей могут быть выбраны для создания линий построения.
Линия, отображающая пересечение с рабочей плоскостью, рисуется цветом этой плоскости. Под линией показано имя рабочей плоскости, к которой она принадлежит. Линия пересечения с плоскостью даёт доступ к параметрам своей исходной плоскости, поэтому для неё доступно контекстное меню.
Когда установлен флаг Не удалять в команде “Удалить лишнее”, плоскость или поверхность не будет удалена, даже если не используется для создания операций.
Опцию удобно применять, например, в случае, если на плоскости или поверхности изображён эскиз, удаление которого из документа нежелательно.
Автоматическая ориентация рабочей плоскости
При создании рабочей плоскости по команде Чертить на грани ориентация рабочей плоскости выбирается таким образом, чтобы она максимально соответствовала текущему направлению взгляда (камеры).

Заданный при создании угол поворота рабочей плоскости не изменяется при редактировании или повторном вызове команды Чертить на рабочей плоскости.
Новый механизм исключает возможность неправильного разворота грани, например, когда грань располагается в перевёрнутом состоянии или поворачивается под неправильным углом.
Камеры и источники света
Камеры и источники света теперь имеют собственные манипуляторы для перемещения и больше не нуждаются в обязательном предварительном создании в сцене локальных систем координат.
С помощью манипуляторов камеры и источники можно расположить в любой точке 3D сцены и быстро переместить в новое положение при необходимости.

Кроме того, для камеры добавлен режим предварительного просмотра, демонстрирующий вид из камеры в режиме реального времени в правом верхнем углу рабочего окна.

В окне параметров можно задать соотношение сторон камеры и размер окна предпросмотра.

Камеру можно создать или выбрать на панели Вид. После выбора используемой камеры на панель Вид добавляются дополнительные опции для камеры.

Был реализован отдельный механизм для перемещения камер. Благодаря этому в режиме выбранной камеры можно перемещаться внутри проектируемых помещений, вращать камеру и при этом выполнять операции, как при обычной работе с T-FLEX CAD.

Опции доступные в режиме выбранной камеры:
Опция
позволяет сохранить текущее положение и перспективу камеры. Если не использовать эту опцию после перемещения/вращения камеры, то камера вернётся в исходное состояние после выхода из режима камеры.
Опция
позволяет вернуть вертикаль камеры в исходное состояние.
Опция
позволяет вернуть положение и ориентацию камеры в исходное/последнее сохранённое состояние.
Управление в режиме выбранной камеры:
ЛКМ – вращение камеры.
Для того чтобы исключить поворот вокруг оси взгляда при вращении нужно включить режим Панорама
.
Стрелки клавиатуры позволяют перемещаться по сцене вперёд/назад.
Page up/Page down позволяют перемещаться вверх/вниз.
При перемещении в режиме выбранной камеры рекомендуется отключать объектную привязку
на панели Вид.
ЛКМ +CTRL – перемещение в плоскости экрана.
ЛКМ +SHIFT – зум.
ЛКМ +ALT – вращение вокруг вертикальной оси.
Нажатое колёсико мыши +CTRL – режим плавного перемещения вперёд/назад. Скорость перемещения изменяется в зависимости от положения курсора.
Вращение колёсика мыши – зум, как перемещение камеры вперёд/назад.
Вращение колёсика мыши +CTRL – зум, как изменение угла перспективы без перемещения камеры.
Длительное нажатие на левую кнопку мыши (до появления символа перекрестья) – орбитальное вращение вокруг выбранного центра.
Для настройки перемещения камеры используется специальная вкладка в диалоге Параметры документа.
Фотореалистичное изображение
К уже существующим механизмам создания фотореалистичных изображений был добавлен новый механизм на основе Embree - ядра трассировки лучей, разработанного Intel.
Для своих расчётов Embree использует центральный процессор и отличается высокой производительностью и качеством изображения.
Интерфейс для работы с этим механизмом идентичен интерфейсу работы с NVIDIA Optix.


Новые инструменты моделирования сборок
При работе со сборкой методом сверху/вниз появилась возможность выгружать из неё доработанные тела или фрагменты. При этом они выгружаются из сборки с сохранением текущей геометрии, дерева построений и переменных. Это позволяет удобно вести проектирование деталей непосредственно в сборочном документе, выгружая эти детали вместе с историей построения лишь на финальном этапе.
Если выгружается фрагмент, который был добавлен в сборку и впоследствии доработан, то его модель, чертежи-проекции, переменные и размеры, если они существовали в исходном файле фрагмента, будут автоматически обновлены в соответствии с этими доработками. Таким образом, можно получать файлы деталей с готовым или почти готовым комплектом чертежей и документацией.
При выгрузке исходное тело или фрагмент в сборке можно заменить выгруженной деталью. Важно, что после такой замены появляется возможность переносить в деталь